Timeline

  • Test

    Created 2 months and 2 weeks ago Florian Bäckmann
    • not all Avatars are displayed

      Created 2 months and 2 weeks ago SnowWh1t3

      Error:

      not all Avatars are displayed

      Solution:

      This caused by late loading of NSFileRepoConnector that sets the $wgUploadPath. Define it in LocalSettings, before loading Avatars, then it works.

      • Test

        Created 2 months and 2 weeks ago P technik

        hfjsdhfjkshfjksdhf

        • TopicTest

          Created 2 months and 2 weeks ago P technik

          TestTest

          • Create Namespace

            Created 2 months and 2 weeks ago P technik

            'Error: "I am not able to create a new namespace on our BlueSpice docu starter site (v.2.23) using Namespace Manager. We have two BlueSpice installations: one runs docu starter (2.23) and the other site runs BlueSpice free (2.22). On the BlueSpice docu starter site, I clicked on Admin > Namespace manager > Add. Entered Test as the namespace name with no options checked and clicked the button to add it. I did not receive a message stating that the namespace was created and Test didn't appear in the namespace list (even after refreshing). The same steps were successful in creating a Test namespace in our BlueSpice free site (v 2.22).

            Solution: The error_log shows problems with writing to the file needed. Please verify the permissions for the config folder found in BlueSpiceFoundation, e.g. execute chmod a+w /var/www/mediawiki/extensions/BlueSpiceFoundation/config For the correct permissions for the folders needed by the apache refer to the installation manual.

            • Create Namespace

              Created 2 months and 2 weeks ago P technik

              'Error: "I am not able to create a new namespace on our BlueSpice docu starter site (v.2.23) using Namespace Manager. We have two BlueSpice installations: one runs docu starter (2.23) and the other site runs BlueSpice free (2.22). On the BlueSpice docu starter site, I clicked on Admin > Namespace manager > Add. Entered Test as the namespace name with no options checked and clicked the button to add it. I did not receive a message stating that the namespace was created and Test didn't appear in the namespace list (even after refreshing). The same steps were successful in creating a Test namespace in our BlueSpice free site (v 2.22).

              Solution: The error_log shows problems with writing to the file needed. Please verify the permissions for the config folder found in BlueSpiceFoundation, e.g. execute chmod a+w /var/www/mediawiki/extensions/BlueSpiceFoundation/config For the correct permissions for the folders needed by the apache refer to the installation manual.

              • No book navigation appears

                Created 2 months and 2 weeks ago P technik

                Error: I have an intallation of BlueSpice docu starter (v. 2.23) with bookmaker extension I installed. can create a book with articles and subarticles in the book manager. However, the navigation for the book does not appear in the Book navigation on the left navigation area. The books are listed. Clicking on a book title displays the first page in the book. No book navigation appears. Only the title of the book as a clickable link that takes you to the first article in the page."

                Solution: "The Bookmaker adds tags to the pages included in the book. You may have a look at the pages included in the book, to reset the tag and insert it in the correct way you could try to save the book again. To do so go to the BookManager (via Special:Specialpages -> BlueSpice -> Book Manager), select the book needed and click on the small arrow next to the save button on the right bottom of the Book Editor. Here select “Save and add book navigation to each article” this time. Afterwards you may revalidate if the problem persists. A restart of the apache is not mandatory but may solve the problem here as well."

                • Waiting Screen

                  Created 2 months and 2 weeks ago P technik

                  Error:

                  Upload of pictures stays in "waiting" screen forever Before uploading, in "Details", existing Categories are not shown like in BS 2.23.3 When cancelling "insert image", picture is available in File Upload Nothing is logged in database logs, php.log, httpd error.log or messages log.

                  Solution: It looks like this is a bug. A required dependency is not being loaded properly. As a work around you can add the following statement to your MediaWiki:Common.js page:

                   /* Bugfix for '"`UNIQ--nowiki-00000000-QINU`"' */
                  mw.loader.using( 'mediawiki.*' ); 
                  
                  • Editing the permissions file manually

                    Created 2 months and 2 weeks ago P technik

                    Error: I managed to mess up permissions. Now nobody can't view Permission Manager to change things back. What should I do?

                    Solution: You can edit the permissions file manually. You will need to connect to the server using a terminal (ssh) or FTP. Edit: /extensions/BlueSpiceFoundation/config/pm-settings.php You can also replace it with: /extensions/BlueSpiceFoundation/config.template/pm-settings.php if you want to reset everything.

                    • All settings for the new group are gone

                      Created 2 months and 2 weeks ago P technik

                      Error: "Is there an up-to-date documentation available for the new Permission Manager. It seems to be intuitive, however I can't get it work? I add a new group via the Group Manager, e.g. qeditor. the new group is written to gm-settings.php - fine. Within the Permission Manager I assign new rights to this group, save - it says permissions saved - fine, however permissions for the new group are not reflected in pm-settings.php. Consequently when reloading the permission manager all settings for the new group are gone?"

                      Solution: This problem has been fixed in BlueSpice 2.23.1

                      How it works The first step to set permissions is to set them in the first folder for the whole wiki (*). The permissions you set for a group, will be set automatically for the following folders, for the wiki and all namespaces (green coloured - not checked). If you want to give the groups more/different permissions - maybe in different namespaces - you can select them manually, but if you do that, the other groups, in the same hierarchy level, lose that permission for the namespace you choosen.

                      • Creating a new namespace

                        Created 2 months and 2 weeks ago P technik

                        '"`UNIQ--nowiki-00000000-QINU`"''Error: "I am not able to create a new namespace on our BlueSpice docu starter site (v.2.23) using Namespace Manager. We have two BlueSpice installations: one runs docu starter (2.23) and the other site runs BlueSpice free (2.22). On the BlueSpice docu starter site, I clicked on Admin > Namespace manager > Add. Entered Test as the namespace name with no options checked and clicked the button to add it. I did not receive a message stating that the namespace was created and Test didn't appear in the namespace list (even after refreshing). The same steps were successful in creating a Test namespace in our BlueSpice free site (v 2.22).

                        Solution: The error_log shows problems with writing to the file needed. Please verify the permissions for the config folder found in BlueSpiceFoundation, e.g. execute chmod a+w /var/www/mediawiki/extensions/BlueSpiceFoundation/config For the correct permissions for the folders needed by the apache refer to the installation manual.

                        • Error: I would like to modify the wiki background and replace the background image. As the admin, I opened the active skin, highlighted it and the skin preview appeared. I uploaded a new background image and saved. The first time I did it, a message appeared to save a file called "api.json". It saved in my downloads folder. I'm not sure what this is and where I should put it. Could you please tell me how to modify the background-image for my "NewSkin" so that it pulls the new graphic?

                          Solution: The problem is browser related, it didn't work with the Internet Explorer,but it works with another broweser like Firefox.

                          • Template is empty

                            Created 2 months and 2 weeks ago P technik

                            Error: Bluespice 2.23.3 MW 1.23.15 LTS I have been trying to create page templates, and I can, but the templates that are presented during page creation, are red letter templates, and the template is empty at the page creation stage. I think what may be the problem is I am unable to choose "Template namespace" during template creation as shown at https://wiki.bluespice.com/index.php/PageTemplates Here is what I see during template creation at the attached file. As you can see the "Template namespace" dialogue is missing. Any help is greatly appreciated.

                            Solution: This is a known bug in 2.23.3 [1]. You will need to update BlueSpiceExtensions to latest REL1_23 branch state (not released as tarball yet). You can find the download here: https://extdist.wmflabs.org/dist/extensions/BlueSpiceExtensions-REL1_23-d78d922.tar.gz You will have to recreate the page templates as the error already got written to the DB. Alternatively you can try to fix the DB entries in bs_pagetemplate.pt_template_title (Remove namespace prefix). [1] https://gerrit.wikimedia.org/r/#/c/295888/

                            • No book navigation appears

                              Created 2 months and 2 weeks ago P technik

                              Error: I have an intallation of BlueSpice docu starter (v. 2.23) with bookmaker extension installed. I can create a book with articles and subarticles in the book manager. However, the navigation for the book does not appear in the Book navigation on the left navigation area. The books are listed. Clicking on a book title displays the first page in the book. No book navigation appears. Only the title of the book as a clickable link that takes you to the first article in the page.

                              Solution: The Bookmaker adds tags to the pages included in the book. You may have a look at the pages included in the book, to reset the tag and insert it in the correct way you could try to save the book again. To do so go to the BookManager (via Special:Specialpages -> BlueSpice -> Book Manager), select the book needed and click on the small arrow next to the save button on the right bottom of the Book Editor. Here select “Save and add book navigation to each article” this time. A restart of the apache is not mandatory but may solve the problem here as well.

                              • How do I force a workflow

                                Created 2 months and 2 weeks ago P technik

                                Error: When updating a page within a Namespace I can force a review using Responsible Editor, but how do I force a workflow to be started?

                                Solution: "That's no standard feature and must be ordered."

                                • adding moderators to pages in the namespaces

                                  Created 2 months and 2 weeks ago P technik

                                  Error: "Currently the option to add a moderator to a page is only available in the Main Namespace. We would also like to be able to add moderators to pages in the namespaces."

                                  Solution: "to add responsible feature on another namespace please do the following steps: index.php?title=Spezial:Wiki_Admin&mode=Preferences -> Responsible editors -> In List "Enabled namespaces" select all entries as needed, save to apply."

                                  • Not all Avatars are displayed

                                    Created 2 months and 2 weeks ago P technik

                                    Error: not all Avatars are displayed

                                    Solution: This caused by late loading of NSFileRepoConnector that sets the $wgUploadPath.

                                    Define it in LocalSettings, before loading Avatars, then it works.

                                    • "waiting" screen

                                      Created 2 months and 2 weeks ago P technik

                                      Error:

                                      Upload of pictures stays in "waiting" screen forever Before uploading, in "Details", existing Categories are not shown like in BS 2.23.3 When cancelling "insert image", picture is available in File Upload Nothing is logged in database logs, php.log, httpd error.log or messages log.

                                      Soluton: It looks like this is a bug. A required dependency is not being loaded properly. As a work around you can add the following statement to your MediaWiki:Common.js page:

                                       /* Bugfix for '"`UNIQ--nowiki-00000000-QINU`"' */
                                      mw.loader.using( 'mediawiki.*' ); 
                                      
                                      • we cannot add files or images

                                        Created 2 months and 2 weeks ago P technik

                                        Error: With the new version of Bluespice and the new version of MW, we cannot add files or images to a page via the file uploader available in the toolbar. Also at Special:Upload the images or file does not render in the preview window upon upload.

                                        Solution: Patch that solves this issue in "Upload image/file" dialog.