Note:Instructions on this page only apply to BlueSpice 3.2.8. They will become obsolote once BlueSpice 3.2.9 is published!

Applying security patches from MediaWiki 1.35.5 to BlueSpice 3

Recent security fixes to MediaWiki 1.35 have been backported to MediaWiki 1.31, which is the base of BlueSpice 3.2. The patches are available for download on SourceForge.

The following instructions are based on Linux installations. But they can be executed in the same way on a Windows system using an appropriate shell, like git bash, cygwin and similar.

Given <bluespice> is the installation path of the BlueSpice wiki application, you can apply the patches like this:#

cd <bluespice>/_bluespice
wget https://sourceforge.net/projects/bluespice/files/BlueSpice-3.2.8-MW1.35.5-fixes.tar.gz
tar xfvz BlueSpice-3.2.8-MW1.35.5-fixes.tar.gz
cd ..
bash _bluespice/pre-autoload-dump.d/99-apply_patches.sh

After a successful run, the output should be like this:

Patching: includes/actions/RollbackAction.php ==> DONE!
Patching: includes/actions/Action.php ==> DONE!
Patching: includes/actions/ViewAction.php ==> DONE!
Patching: includes/specials/SpecialChangeContentModel.php ==> DONE!
Patching: includes/MediaWiki.php ==> DONE!
Patching: includes/EditPage.php ==> DONE!
Patching: extensions/VisualEditor/modules/ve-mw/ui/dialogs/ve.ui.MWMediaDialog.js ==> DONE!

There may be additional lines of output, based on the edition of BlueSpice.

No categories assignedEdit

Discussions

Attachments