Last edited 6 months ago
by MLR

System requirements

Revision as of 12:14, 14 February 2023 by MLR (talk | contribs)


For a trouble-free installation of the current version of BlueSpice 4, we recommend the following system requirements.

Browser

  • Microsoft Edge
  • Google Chrome
  • Firefox

Server Environment

Warning!PHP version 8.1 is currently not supported!
  • Operating system:
    • We strongly recommend Linux (preferably Debian 11, Ubuntu 22.04, CentOS 7)
    • You might use Windows Server starting at 2016, but we have seen performance issues on Windows Server
  • Webserver:
    • Apache 2.4.x, IIS >= 10 or nginx 1.x (nginx not possible in WikiFarm)
  • PHP:
    • PHP 7.4: BlueSpice 4.2.x runs completely stable
    • PHP 8.0: Starting with BlueSpice 4.2.4
    • PHP 8.1: Starting from BlueSpice 4.3.x (in planning)
  • Database:
    • MySQL: >= 5.6 or
    • MariaDB >= 10.3
  • (Virtual) hardware requirements:
    • CPU:
      • Linux: 8 Cores (min. 4 Cores)
      • Windows: 16 Cores (min. 8 Cores)
    • Main memory:
      • Linux: 16 GB (min. 8GB)
      • Windows: min. 16 GB
    • Available hard drive space:
      • > 20 GB (depends on the planned storage of data)
  • Other:
    • Apache Tomcat >= 9 oder Jetty >= 9 (for PDF export and LaTexRenderer)
    • ElasticSearch 6.8 with plugin “ingest-attachment”
    • OpenJDK >= 10
    • NodeJS 16



To submit feedback about this documentation, visit our community forum.

Discussions