Difference between revisions of "Setup:System requirements"

 
Line 12: Line 12:
 
==Server Environment==
 
==Server Environment==
 
{{Messagebox|boxtype=warning|icon=yes|Note text=PHP '''version 8.1'''  is currently not supported!|bgcolor=}}
 
{{Messagebox|boxtype=warning|icon=yes|Note text=PHP '''version 8.1'''  is currently not supported!|bgcolor=}}
*Operating system: Microsoft Windows Server >= 2016 or Linux (common distributions)
+
*Operating system: Linux recommended (preferably Ubuntu or Debian), Microsoft Windows Server >= 2016 possible, but lower performance
 
*Webserver: <span style="color: rgb(68, 68, 68)">Apache 2.4.x, IIS >= 10 ''or'' nginx 1.x</span> (''nginx'' ''not possible in WikiFarm'')
 
*Webserver: <span style="color: rgb(68, 68, 68)">Apache 2.4.x, IIS >= 10 ''or'' nginx 1.x</span> (''nginx'' ''not possible in WikiFarm'')
 
*PHP 7.4.x starting at 7.4.3 or PHP 8.0
 
*PHP 7.4.x starting at 7.4.3 or PHP 8.0

Latest revision as of 14:16, 23 November 2022


For a trouble-free installation of the current version BlueSpice 4, we recommend the following system requirements. The application BlueSpice is tested by Hallo Welt! for Windows and Linux.

Browser[edit | edit source]

  • Microsoft Edge
  • Google Chrome
  • Firefox

Server Environment[edit | edit source]

Warning!PHP version 8.1 is currently not supported!
  • Operating system: Linux recommended (preferably Ubuntu or Debian), Microsoft Windows Server >= 2016 possible, but lower performance
  • Webserver: Apache 2.4.x, IIS >= 10 or nginx 1.x (nginx not possible in WikiFarm)
  • PHP 7.4.x starting at 7.4.3 or PHP 8.0
  • MySQL: >= 5.6 oder MariaDB >= 10.3
  • Main memory: 16 GB (minimal 8 GB)
  • Available hard drive space: > 20GB (depends on the planned storage of data)
  • CPU: 8 (minimal 4) cores
  • Apache Tomcat >= 9 oder Jetty >= 9 (for PDF export and LaTexRenderer)
  • ElasticSearch 6.8 with plugin “ingest-attachment”
  • OpenJDK >= 10
  • NodeJS 16

Discussions