Difference between revisions of "Setup:System requirements"

[quality revision][quality revision]
(Changed categories.)
m
(Tag: 2017 source edit)
 


For a trouble-free installation of the current version BlueSpice 3.12, we recommend the following system requirements. The application BlueSpice is tested by Hallo Welt! for Windows and Linux.

MediaWiki[edit | edit source]

  • Version 1.31.x (LTS -Long Term Support)

Browser[edit | edit source]

  • Internet Explorer 11 or higher (without compatibility view)
  • Microsoft Edge
  • Google Chrome
  • Firefox

Server Environment[edit | edit source]

  • Operating System: Microsoft Windows Server 2012+ or Linux (established distributions)
  • Webserver: Apache 2+, nginx 1+(*) or IIS 8+ , 9, 10 (*)nginx not possible in WikiFarm
  • PHP 7.2+.x, 7.3.x
  • MySQL 5.6+ or MariaDB 10+.x
  • Main Memorymemory: 16GB (minimal 8GB)
  • Hard DriveAvailable hard drive space: > 20 GB 20GB (depends on the planned storage of data)
  • CPU: 8 (minimal 4) cores
  • Apache Tomcat 8 of or Jetty 9 (for PDF export, version comparison, and LaTexRenderer)
  • ElasticSearch 6.x ( with plugin "ingest-attachment")
  • Java 8+.x or OpenJDK 10+.x
  • NodeJS 8+.x, 9.x, 10.x


Database access[edit | edit source]

  • Host/IP adress and port
  • User name and password for root user (Create/Drop statements) and wiki user (has possibly been created during the MediaWiki installation)
  • Name of the database
  • The table prefix of the database


{{DISPLAYTITLE:System Requirements 3.12}}
        
        __NOTOC__
        

        For a trouble-free installation of the current version BlueSpice 3.12, we recommend the following system requirements. The application BlueSpice is tested by Hallo Welt! for Windows and Linux.
        

        ==MediaWiki==
        

        *Version 1.31.x (LTS -Long Term Support)
        

        ==Browser==
        

        *Internet Explorer 11 or higher (without compatibility view)
        
        *Microsoft Edge
        
        *Google Chrome
        
        *Firefox
        

        ==Server Environment==
        

        *Operating System: Microsoft Windows Server 2012+ or Linux (established distributions)
        
        *Webserver: Apache 2+, nginx 1+<sup>(*)</sup> or IIS 8+    <sup>(*)</sup> , 9, 10    <sup>(*)</sup>''nginx not possible in WikiFarm''
        
        *PHP 7.2+
            .x, 7.3.x
            *MySQL 5.6+ or MariaDB 10+.x
        
        *Main Memory:memory: 16GB (minimal 8GB)
        
        *Hard Drive: > 20 GB Available hard drive space: > 20GB (depends on the planned storage of data)
        
        *CPU: 8 (minimal 4) cores
            *Apache Tomcat 8 ofor Jetty 9 (for PDF export, version comparison, and LaTexRenderer)
        
        *ElasticSearch 6.x (with plugin "ingest-attachment")
        
        *Java 8+.x or OpenJDK 10+.x
        
        *NodeJS 8+
            
.x, 9.x, 10.x
            
==Database access==
        

        *Host/IP adress and port
        
        *User name and password for root user (Create/Drop statements) and wiki user (has possibly been created during the MediaWiki installation)
        
        *Name of the database
        
        *The table prefix of the database
        
<bs:universalexport:noexport>
        
        ==Archive: System requirements of older BlueSpice versions==
        
        * [[Media:BlueSpice_System_Requirements_V301.pdf|BlueSpice version 3.0.1]]
        
        * [[Media:BlueSpice_System_Requirements_V2272.pdf|BlueSpice version 2.27.2/2.27.3]]
        
        * [[Media:BlueSpice_System_Requirements_V2271.pdf|BlueSpice version 2.27.1]]
        
        * [[Media:BlueSpice_System_Requirements_V2270.pdf|BlueSpice version 2.27.0]]
        
        * [[Media:BlueSpice_System_Requirements_V2233.pdf|BlueSpice version 2.23.3]]
        
        * [[Media:BlueSpice_System_Requirements_V2232.pdf|BlueSpice version 2.23.2]]
        
        * [[Media:BlueSpice_System_Requirements_V222x.pdf|BlueSpice version 2.22.x]]
        
        * [[Media:BlueSpice_System_Requirements_V1210.pdf|BlueSpice version 1.21.0]]
        </bs:universalexport:noexport>
        

        [[en:{{FULLPAGENAME}}]]
        
        [[de:Setup:Systemanforderungen]]
        
        [[Category:Setup]]
(One intermediate revision by the same user not shown)
Line 1: Line 1:
{{DISPLAYTITLE:System Requirements 3.1}}
+
{{DISPLAYTITLE:System Requirements 3.2}}
 
__NOTOC__
 
__NOTOC__
  
For a trouble-free installation of the current version BlueSpice 3.1, we recommend the following system requirements. The application BlueSpice is tested by Hallo Welt! for Windows and Linux.
+
For a trouble-free installation of the current version BlueSpice 3.2, we recommend the following system requirements. The application BlueSpice is tested by Hallo Welt! for Windows and Linux.
  
 
==MediaWiki==
 
==MediaWiki==
Line 18: Line 18:
  
 
*Operating System: Microsoft Windows Server 2012+ or Linux (established distributions)
 
*Operating System: Microsoft Windows Server 2012+ or Linux (established distributions)
*Webserver: Apache 2+, nginx 1+<sup>(*)</sup> or IIS 8+   <sup>(*)</sup> ''nginx not possible in WikiFarm''
+
*Webserver: Apache 2, nginx 1+<sup>(*)</sup> or IIS 8, 9, 10   <sup>(*)</sup>''nginx not possible in WikiFarm''
*PHP 7.2+
+
*PHP 7.2.x, 7.3.x
*MySQL 5.6+ or MariaDB 10+
+
*MySQL 5.6+ or MariaDB 10.x
*Main Memory:16GB (minimal 8GB)
+
*Main memory: 16GB (minimal 8GB)
*Hard Drive: > 20 GB (depends on the planned storage of data)
+
*Available hard drive space: > 20GB (depends on the planned storage of data)
*CPU: 8 (minimal 4)
+
*CPU: 8 (minimal 4) cores
*Apache Tomcat 8 of Jetty 9 (for PDF export, version comparison and LaTexRenderer)
+
*Apache Tomcat 8 or Jetty 9 (for PDF export, version comparison, and LaTexRenderer)
*ElasticSearch 6.x (with plugin "ingest-attachment")
+
*ElasticSearch 6.x with plugin "ingest-attachment"
*Java 8+or OpenJDK 10+
+
*Java 8.x or OpenJDK 10.x
*NodeJS 8+
+
*NodeJS 8.x, 9.x, 10.x
  
  

Attachments

Discussions